Skip to main content

View Post [edit]

Poster: vanark Date: Feb 28, 2019 5:37pm
Forum: etree Subject: Re: Issues with new uploader

1a, 1b, ad 1c - this has previously been forwarded to the developer to prohibit proceeding unless they have selected the artist from the list. No match, no proceeding to the next page.

2a. Reported to the developer on day 1 of release. Hoping for this to be fixed soon.

2b. MD5 field has no real value any longer. If someone needs to see the MD5, they can download the MD5 file. The field had no functional value. As for Notes, I suggest you simply include them in the Description field.

2e. Agree - We'll ask the developer to remove it altogether.

3. We previously requested that the Populate buttons simply be eliminated and the fields be autopopulated with the Artist and Date/Venue fields. In the previous workflow, you would not have the Venue until you get to the metadata screen, but now you have that information before the files are uploaded.

Hope that helps. Thank you for the valuable feedback - very much appreciated. As you can see, many of the items are already in the works, although we don't yet have an ETA on changes.

Feel free to email us at etree at archive dot org if you want to discuss.

Reply [edit]

Poster: gilde Date: Mar 1, 2019 10:43am
Forum: etree Subject: Re: Issues with new uploader

Thanks very much!

Reply [edit]

Poster: Jhudson844 Date: Mar 4, 2019 6:28pm
Forum: etree Subject: Re: Issues with new uploader

I really don't care for it. Now I am trying to upload and keep getting "bad data" errors.

<?xml version='1.0' encoding='UTF-8'?>
BadContentUploaded content is unacceptable.Item metadata collection value refers to nonexistant collection: af773888-8dd6-4f98-99d6-7a25d4dd16ea

How much do I have to donate to get the classic uploader back ;)

Reply [edit]

Poster: vanark Date: Mar 5, 2019 5:01am
Forum: etree Subject: Re: Issues with new uploader

In addition to Jeff's suggestion (which I think is fixed now), we are also seeing it when you don't select the band from the list, but rather manually type the band's name out fully. Once you type enough of the band's name to get a match, simply select it from the list rather than type it out. The issues you describe usually result from a typo in the band name which is prevented if you select it from the list.

If you can't find the band in the list, please email us at etree at archive dot org with the details and we'll assist in sorting it out.

Reply [edit]

Poster: Jhudson844 Date: Mar 5, 2019 6:07am
Forum: etree Subject: Re: Issues with new uploader

Thanks Rory looks like that was it.

Reply [edit]

Poster: Jhudson844 Date: Mar 5, 2019 9:51am
Forum: etree Subject: Re: Issues with new uploader

Although now it's not deriving for some reason. When I try to manually derive, it says there's already a task. I tried the old tried and true method of turning off lossless, waiting 5 minutes and turning it back on no dice. Any suggestions please? https://archive.org/details/yarn2016-02-27.flac16 Thanks again!

Reply [edit]

Poster: vanark Date: Mar 5, 2019 1:07pm
Forum: etree Subject: Re: Issues with new uploader

One of your apostrophe's is a curly apostrophe, not UTF-8 encoded. I'll fix it and upload a new copy of the text file. Then restart the derive.

This most often happens when using a text editor where the encoding is not set to Unicode UTF-8. It will look like plain text, but it is encoded at some high bit character setting. If you look the file, you will see the offending characters as question marks in a black diamond instead of the character. What I have seen this week is problems with curly apostrophes (" ’ ", tildes ("ñ"), and accented characters ("é"). The derive fails and no files are created for the player to use.

The solution is to make sure you are using a plain text editor with encoding set to UTF-8. Suggest by the support team at Internet Archive are textedit (in plain text mode), bbedit, textwrangler or others. I personally use Editpad Lite with the encoding set to Unicode, UTF-8.

Reply [edit]

Poster: Jhudson844 Date: Mar 5, 2019 2:32pm
Forum: etree Subject: Re: Issues with new uploader

Ahh yes, I copied and pasted one of the song names from the web into the Windows Notepad file after looking it up to confirm it online (Fussin' and Fightin'). Had I not been lazy and manually typed it, Notepad would have encoded it properly. Can we get facepalm emojis for the forum?

Thanks again!

Reply [edit]

Poster: Jeff Kaplan Date: Mar 4, 2019 7:30pm
Forum: etree Subject: Re: Issues with new uploader

what is the collection/band you were trying to upload to? the issue seems to be with collections that do not yet have any uploads.